Power BI update -Gateway recovery key, move to .Net framework 4 – Ask Synergy Software Systems, Dubai’s Power App specialist.

December 5th, 2019 by Stephen Jones Leave a reply »

The November update for the On-premises data gateway (version 3000.14.39) is released.

Change Gateway Recovery Key
The recovery key provided by gateway admins during installation of on-premises data gateways in a standard mode could not be changed in the past. This key is used to create the symmetric key which in turn is used for encrypting credentials in data sources/connections using that gateway. With the November release of Data Gateways, you will now be able to rotate this key. More information about recovery keys, detailed description on how to perform this change and associated limitations can be found in the data gateway docs.

November version of the mashup engine
This month’s Gateway update also includes an updated version of the Mashup Engine. This will ensure that the reports that you publish to the Power BI Service and refresh via the Gateway will go through the same query execution logic/runtime as in the latest Power BI Desktop version.

Please note that this upcoming change may impact you:
PB1 will be using .NET 4.8 framework for gateways February 2020 version or higher hence some of the operating systems it used to support may no longer be supported. i.e. for many this change will also force a Windows update.

All .NET Framework versions since .NET Framework 4 are in-place updates, so only a single 4.x version can be present on a system.
In addition, particular versions of the .NET Framework are pre-installed on some versions of the Windows operating system. This means that:
• If there’s a later 4.x version installed on the machine already, then you can’t install a previous 4.x version.
• If the OS comes pre-installed with a particular .NET Framework version, then you can’t install a previous 4.x version on the same machine.
• If you install a later version, you don’t have to first uninstall the previous version.
• The .NET Framework requires administrator privileges for installation.

Advertisement

Comments are closed.